Менеджер OSS PBX End Point Установка.

OSS PBX End Point Manager is the free supported PBX Endpoint Manager for FreePBX

Идем по вкрадкам
Администратор -> Управление модулями

В разделе Подключения ищем модуль Менеджер OSS PBX End Point, далее Активировать -> Запустить процесс
В верхнем меню появиться:
Расширенные настройки OSS Endpoint, Список устройств OSS Endpoint, Менеджер пакетов OSS Endpoint, Менеджер шаблонов OSS Endpoint.

Далее по порядку.

1. Установка tftp сервера.
# yum install tftp tftp-server
# yum install xinetd
Зададим права на директорию для файлов:

# chown -R asterisk:asterisk /var/lib/tftpboot
Отредактируем файл /etc/xinetd.d/tftp

service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = asterisk
server = /usr/sbin/in.tftpd
server_args = -s /var/lib/tftpboot
disable = no
per_source = 11
cps = 50 10
flags = IPv4
}

Применим настройки.

/etc/rc.d/init.d/xinetd restart

2. Менеджер пакетов OSS Endpoint
Обновить и выбрать те телефоны которые будут использоваться. Установить пакеты. Можно отключить не нужные, добавив их в скрытые просто нажав Х на бренде.

3. Расширенные настройки OSS Endpoint Настраиваем
Вкладка Установки
ИП адрес сервера телефонии
Тип конфигурации tftp/ftp
Директория для глобальных окончательных конфигураций и прошивок /var/lib/tftpboot/

Вкладка Редактор конфигурации продукта
С права выбираем модель телефона и получаем 2 файла y0000000000$suffix.cfg и $mac.cfg сохраняем их под другим именем например y000000000039.cfg и mac_t19.cfg
Получаем два файла Пользовательских конфигураций

4. Менеджер шаблонов OSS Endpoint
Создаем шаблон на основе Пользовательских конфигураций для выбранной модели телефона

5. Список устройств OSS Endpoint
Подключаем устройства

Теперь самое главное сообщить устройству что конфигурацию надо брать именно от туда. Делаеться это с помощью DHCP Сервера который передает option 66 со значением IP FREEPBX TFTP и option 128 со значением IP FREEPBX TFTP
Мы использовали Роутер Mikrotik
/ip dhcp-server option
add code=66 name=option66 value="s'XXX.XXX.0.7'"
add code=128 name=option128 value="s'XXX.XXX.0.7'"
/ip dhcp-server option sets
add name=yealink options=option66,option128
/ip dhcp-server network
add address=XXX.XXX.0.0/24 caps-manager=XXX.XXX.0.1 dhcp-option-set=yealink dns-server=XXX.XXX.0.1 domain=office.loc gateway=XXX.XXX.0.1 netmask=24 ntp-server=XXX.XXX.0.1

Удачи, Всем спасибо.